Witamy na forum PC Format Zapraszamy do REJESTRACJI


Użytkownicy przeglądający ten wątek: 1 gości

Problem z Eclipse (programowanie mikrokontrolera za pomocą USBasp)

#1
Problem z Eclipse (programowanie mikrokontrolera za pomocą USBasp)
Witam.
Nie wiem czy wybrałem odpowiedni dział, jeżeli nie proszę o przeniesienie.
Mam problem z programem ,,Eclipse".
Mianowicie wszystko mam skonfigurowane, program napisany prawidłowo. Przy kompilacji nie wywala błędów, program zapisany na dysku. Programator ustawiony na programowanie (zworka na ,,service") Jednak podczas przesyłania programu do mikrokontrolera występuje taki błąd:

Kod:
Launching C:\WinAVR\bin\avrdude -pm8 -cusbasp -Uflash:w:qwerty.hex:a 
Output:

avrdude: error: usbasp_transmit: usb_control_msg: sending control message failed, win error: A device attached to the system is not functioning.


avrdude finished
Co może być nie tak?
Mikrokontroler: ATmega8A
Programator: AVR USBasp

Jestem początkujący, proszę o pomoc i z góry dziękuję.
Pozdrawiam.
http://www.it-science.pl/ - zapraszam na srtonę. Wesoły
Całkowicie zmieniony układ strony. Jest teraz bardziej przejrzysta i czytelniejsza.
 System operacyjny: windows_seven Przeglądarka: chrome
#2
RE: Problem z Eclipse (programowanie mikrokontrolera za pomocą USBasp)
Gdzie tu jest problem z Eclipse? Błąd wskazuje, że nie wykrywa urządzenia (urządzenie nie działa). Prawdopodobne przyczyny to:
1. Nieprawidłowa wersja aplikacji avrdude
2. Nieprawidłowa konfiguracja avrdude.conf
 System operacyjny: windows_seven Przeglądarka: firefox
#3
RE: Problem z Eclipse (programowanie mikrokontrolera za pomocą USBasp)
Niestety mimo usilnych prób nie udało mi się zaktualizować/wgrać nowszej wersji avrdude. Mam 5.10 próbuję aktualizować do 5.11 i nici.
koneton - czy możesz mi pomóc, wytłumaczyć jak to wszystko zrobić?
Pobrałem Arduino IDE i próbowałem na nim, ale te sam błąd wyskakuje więc wiadomo na 100%, że winnym jest avrdude.
Proszę o pomoc.
http://www.it-science.pl/ - zapraszam na srtonę. Wesoły
Całkowicie zmieniony układ strony. Jest teraz bardziej przejrzysta i czytelniejsza.
 System operacyjny: windows_seven Przeglądarka: chrome
#4
RE: Problem z Eclipse (programowanie mikrokontrolera za pomocą USBasp)
Niestety, nie używałem Arduino. Znam tylko Eclipse i umiem czytać dokumentację oraz fora.  ;)

Avrdude 5.11 dla Windows:
http://download.savannah.gnu.org/release...-win32.zip

Wydaje mi się, że na forum związanym z Arduino szybciej znajdziesz pomoc. Np.:
https://forums.adafruit.com/viewtopic.ph...p;p=229391
 System operacyjny: windows_seven Przeglądarka: firefox
#5
RE: Problem z Eclipse (programowanie mikrokontrolera za pomocą USBasp)
Okazało się, że zaktualizowałem Avrdude do wersji 5.11. Niby wszystko ok: mikrokontroler podłączony dobrze, odpowiednie zworki na programatorze "ustawione" odpowiednio, kompilacja programu przebiega bezproblemowa (wszystkie pliki się tworzą a kompilator nie wyświetla błędów), a mimo wszystko ten błąd pojawia się nadal...
No nic, będę szukał, próbował, może się uda Wesoły

Zworki muszą być na power oraz slow.
A ja się tyle męczyłem. Czytając tyle poradników, itd można zgłupieć Very Happy
Mikrokontroler zaprogramowany.
Dziękuję, pozdrawiam.
http://www.it-science.pl/ - zapraszam na srtonę. Wesoły
Całkowicie zmieniony układ strony. Jest teraz bardziej przejrzysta i czytelniejsza.
 System operacyjny: windows_seven Przeglądarka: chrome
Programy: Polecane / Nowe / Inne




Podobne wątki (Problem z Eclipse (programowanie mikrokontrolera za pomocą USBasp))
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Jak daleko dojdę, jeśli programowanie nie jest „palącą pasją”? YekinKebo 1 1982 26.09.2021, 17:29
Ostatni post: NvidiaIntel93
  Programowanie dla laika - od czego zaczac? adiq1033 10 11982 28.05.2021, 12:58
Ostatni post: crmdesigner
  Pytanie - programowanie batch [cmd] Max23 0 14249 20.03.2020, 01:03
Ostatni post: Max23

Skocz do: