Witamy na forum PC Format Zapraszamy do REJESTRACJI


Użytkownicy przeglądający ten wątek: 1 gości

Problem z linkami

#1
Question  Problem z linkami
Cześć,

Założyłem blog stop-limitom.pl i niestety mam jakiś problem z linkami.
Generalnie chodzi o to że jak klikam w jakiś post w tym przypadku "oglądaj" i przechodzę na stronę posta adres URL pozostaje bez zmian czyli strona głownastop-limitom.pl.
Powinien się zaś zmienić na ustaloną w panelu admina ścieżkę czyli /index.php/%postname%/.
Dodatkowo jak jestem na tym poście i odświeżę stronę to wraca mnie na stronę główną nie zależnie od tego na jakiej podstronie czy też poście bym się znajdował.

Jak kliknę na button "oglądaj" prwaym myszki i otwórz w nowej karcie to wtedy post otwiera się z prawidłowym linkiem i wszystko działa. Wiecie może w czym tkwi problem? Będę wdzięczny za info.

Problem ten występuje już na 3 wersji bloga 3.1.2 się zaczęło i teraz na 3.1.4jest to samo
 System operacyjny: windows_seven Przeglądarka: chrome
#2
RE: Problem z linkami
Podepnij DNS-y.
[Obrazek: musicbar.php?username=hatesz&color=red&u...unicode=no]
 System operacyjny: windows_seven Przeglądarka: chrome
#3
RE: Problem z linkami
Rozumiem że mam to zrobić na serwerze na którym jest postawiony blog. W moim przypadku jest to home.pl.
Skąd mogę wziąć DNS wordpress? Czy o jakie DNS chodzi?
 System operacyjny: windows_seven Przeglądarka: chrome
#4
RE: Problem z linkami
Tam gdzie masz hosting (w panelu) wstaw adresy serwerów DNS domeny.
[Obrazek: musicbar.php?username=hatesz&color=red&u...unicode=no]
 System operacyjny: windows_seven Przeglądarka: chrome
#5
RE: Problem z linkami
Czy przypadkiem nie jest to przez to, że dajesz index.php? Ustaw samo /%postname%/ i zobacz czy coś się zmieni.
Blog angielski do zarabiania
Taki sobie linux a dokładniej to fedora
 System operacyjny: windows_seven Przeglądarka: firefox
#6
RE: Problem z linkami
Dałem samo /%postname%/ ale nadal ten sam błąd Smutek
Domena i serwer jest na home więc z tego co widzę DNS automatycznie się importują
 System operacyjny: windows_seven Przeglądarka: chrome
#7
RE: Problem z linkami
Masz stronę wstawioną w ramce. Twój plik index.php to
Kod:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "http://www.w3.org/TR/html4/frameset.dtd">
<HTML><HEAD><TITLE></TITLE></HEAD>
<FRAMESET ROWS="*"><FRAME NAME=997 NORESIZE SRC="http://headadmin.home.pl">
<NOFRAMES><BODY><A HREF="http://headadmin.home.pl">click here</A></BODY></NOFRAMES></FRAMESET></HTML>

Wszystkie pliki WP masz w folderze innej domeny (headadmin.home.pl). Przenieś je do folderu Twojej domeny.
 System operacyjny: windows_seven Przeglądarka: chrome
#8
RE: Problem z linkami
Problem rozwiązany Wesoły

Tkwił w źle podpiętej domenie. Miałem zrobione tylko przekierowanie, a powinna być przypisana do usługi serwera.

Jeżeli chodzi o index.php to udało mi sie to ominąć w ten sposób:
wystarczy edytować plik wp-includes/vars.php i zamienić linijkę:
Kod

Cytat:$is_apache = (strpos($_SERVER['SERVER_SOFTWARE'], 'Apache') !== false || strpos($_SERVER['SERVER_SOFTWARE'], 'LiteSpeed') !== false);
na to:
Kod

Cytat:$is_apache = (strstr($_SERVER['SERVER_SOFTWARE'], 'Apache') || strstr($_SERVER['SERVER_SOFTWARE'], 'LiteSpeed') || strstr($_SERVER['SERVER_SOFTWARE'], 'IdeaWebServer')) ? 1 : 0;
a potem jeszcze raz zapisać ustawienia bezpośrednich odnośników.

Pomógł ~Htsz

Temat do zamknięcia Wesoły
 System operacyjny: windows_seven Przeglądarka: chrome
Programy: Polecane / Nowe / Inne




Podobne wątki (Problem z linkami)
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
Sad Domena na home.pl i problem z linkami zewnętrznymi. Loska 4 2448 23.02.2013, 21:47
Ostatni post: Loska
  Skrypt Lubie To na stronie Połączony z Linkami GTWMarek 1 2223 27.07.2012, 15:12
Ostatni post: Ajgor
  Pytanie o boczny prawy pasek z banerami i linkami dla forum MyBB GALLUS123 4 4841 07.06.2010, 02:14
Ostatni post: DamYan

Skocz do:


Wybrane wątki (Problem z linkami)
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Gotowe klasy xCart 0 5346 08.02.2019 17:16
Ostatni post: xCart
  Jak ustawić tekst na środku ekranu buzek1 4 2915 08.02.2019 17:07
Ostatni post: xCart
Ściana Problem a zaktualizacją Joomla 3.6.5 do 3.8.8 CREATIVE_ 14 21040 13.01.2019 06:00
Ostatni post: CREATIVE_
  Xampp i CMS Made Simple Echelon 1 6397 07.12.2018 14:35
Ostatni post: raxer
  Problem z certyfikatem na sslforfree.com gentleman 2 7638 11.10.2018 17:09
Ostatni post: Michu_PL
  Generator kodów kreskowych Yanke$ 0 7997 16.09.2018 12:02
Ostatni post: Yanke$
  skalowanie elementów do wielkości ekranu szakal87 1 8263 11.09.2018 05:36
Ostatni post: Michu_PL
  Formularz do zgłaszania błędów na stronie-pomoc w przeróbce. raxer 0 7579 10.09.2018 18:51
Ostatni post: raxer
  Layout Strony Majki_77 2 8985 28.08.2018 16:27
Ostatni post: gentleman
  Wyszukiwanie na urządzenich mobilnych broda99 4 2543 22.08.2018 13:14
Ostatni post: grzegorzkrk
  Zmiana rozmiaru okna przeglądarki a marginesy Wacho 0 7877 09.08.2018 23:15
Ostatni post: Wacho
  Stworzenie nowej strony na Wordpressie Majki_77 8 9107 22.07.2018 22:21
Ostatni post: ada1986
Ściana Dynamiczne pobieranie html PHP kamiltu 0 8546 23.06.2018 15:53
Ostatni post: kamiltu
  Tworzenie stron (Usługa) Majki_77 2 8541 21.06.2018 08:13
Ostatni post: Michu_PL
Ściana HTML5, CSS, Jak ustawić logo strony ze zdjecia jootiii 1 1533 10.06.2018 14:40
Ostatni post: raxer